import Foundation
let pattern = #"^(.+) > проверить, что элемент коллекции \"(.+)\" коллекции под номером (\d+) находится в состоянии (доступен|не доступен)(?: для редактирования|)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"То Проблемы_ОбновлениеПолей > проверить, что элемент коллекции "Поле Статус" коллекции под номером 2 находится в состоянии не доступен для редактирования"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)