package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.+) > проверить, что элемент коллекции \"(.+)\" коллекции под номером (\d+) находится в состоянии (доступен|не доступен)(?: для редактирования|)$`)
var str = `То Проблемы_ОбновлениеПолей > проверить, что элемент коллекции "Поле Статус" коллекции под номером 2 находится в состоянии не доступен для редактирования`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}