const regex = new RegExp('(?=^\\d+[a-z]+(?:-\\d+[a-z]+)*$)(?:(?<gal>\\d+)gal(?=-|$))?-?(?:(?<qt>\\d+)qt(?=-|$))?-?(?:(?<pt>\\d+)pt(?=-|$))?-?(?:(?<cup>\\d+)cup(?=-|$))?-?(?:(?<oz>\\d+)oz)?$', 'gm')
const str = `1gal-1qt-2pt-2cup-5oz
1qt-1gal-2pt-2cup-5oz
1gal-6oz
1gal
6oz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}