re = /(?=^\d+[a-z]+(?:-\d+[a-z]+)*$)(?:(?<gal>\d+)gal(?=-|$))?-?(?:(?<qt>\d+)qt(?=-|$))?-?(?:(?<pt>\d+)pt(?=-|$))?-?(?:(?<cup>\d+)cup(?=-|$))?-?(?:(?<oz>\d+)oz)?$/m
str = '1gal-1qt-2pt-2cup-5oz
1qt-1gal-2pt-2cup-5oz
1gal-6oz
1gal
6oz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end