import Foundation
let pattern = #"(?=^\d+[a-z]+(?:-\d+[a-z]+)*$)(?:(?<gal>\d+)gal(?=-|$))?-?(?:(?<qt>\d+)qt(?=-|$))?-?(?:(?<pt>\d+)pt(?=-|$))?-?(?:(?<cup>\d+)cup(?=-|$))?-?(?:(?<oz>\d+)oz)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1gal-1qt-2pt-2cup-5oz
1qt-1gal-2pt-2cup-5oz
1gal-6oz
1gal
6oz
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)