use strict;
my $str = '1gal-1qt-2pt-2cup-5oz
1qt-1gal-2pt-2cup-5oz
1gal-6oz
1gal
6oz';
my $regex = qr/(?=^\d+[a-z]+(?:-\d+[a-z]+)*$)(?:(?<gal>\d+)gal(?=-|$))?-?(?:(?<qt>\d+)qt(?=-|$))?-?(?:(?<pt>\d+)pt(?=-|$))?-?(?:(?<cup>\d+)cup(?=-|$))?-?(?:(?<oz>\d+)oz)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}