# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s+\((?:[^)(]+|\((?:[^)(]+|\([^)(]*\))*\))*\)//gm;t' <<< "Rwanda (/ruˈɑːndə, -ˈæn-/ (About this soundlisten); Kinyarwanda: U Rwanda [u.ɾɡwaː.nda] (About this soundlisten)), officially the Republic of Rwanda (Kinyarwanda: Repubulika y'u Rwanda; Swahili: Jamhuri ya Rwanda; French: République du Rwanda)..."