use strict;
my $str = 'Rwanda (/ruˈɑːndə, -ˈæn-/ (About this soundlisten); Kinyarwanda: U Rwanda [u.ɾɡwaː.nda] (About this soundlisten)), officially the Republic of Rwanda (Kinyarwanda: Repubulika y\'u Rwanda; Swahili: Jamhuri ya Rwanda; French: République du Rwanda)...';
my $regex = qr/\s+\((?:[^)(]+|\((?:[^)(]+|\([^)(]*\))*\))*\)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";