re = /\s+\((?:[^)(]+|\((?:[^)(]+|\([^)(]*\))*\))*\)/m
str = 'Rwanda (/ruˈɑːndə, -ˈæn-/ (About this soundlisten); Kinyarwanda: U Rwanda [u.ɾɡwaː.nda] (About this soundlisten)), officially the Republic of Rwanda (Kinyarwanda: Repubulika y\'u Rwanda; Swahili: Jamhuri ya Rwanda; French: République du Rwanda)...'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result