using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+\((?:[^)(]+|\((?:[^)(]+|\([^)(]*\))*\))*\)";
string substitution = @"";
string input = @"Rwanda (/ruˈɑːndə, -ˈæn-/ (About this soundlisten); Kinyarwanda: U Rwanda [u.ɾɡwaː.nda] (About this soundlisten)), officially the Republic of Rwanda (Kinyarwanda: Repubulika y'u Rwanda; Swahili: Jamhuri ya Rwanda; French: République du Rwanda)...";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}