using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"POINT\((?P<longitude>-?\d+\.\d+) (?P<latitude>-?\d+\.\d+)\)";
string input = @"POINT(-6.81015 52.448501)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}