package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)POINT\((?P<longitude>-?\d+\.\d+) (?P<latitude>-?\d+\.\d+)\)`)
var str = `POINT(-6.81015 52.448501)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}