// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)POINT\((?P<longitude>-?\d+\.\d+) (?P<latitude>-?\d+\.\d+)\)").unwrap();
let string = "POINT(-6.81015 52.448501)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}