# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\)[;,]( )|([A-Z\d]+))|./$2$1/gm;t' <<< "4A(4,5,6,7,8,9); 4B(4,5,7,8); 3A(1,2,3); 3B(1,2,3), 3C(1,2)
4A (4,5,6,7,8,9); 4B(4,5,7,8); 3A(1,2,3); 3B(1,2,3), 3C(1,2)
4A (4,5, skip 8,9); 4B(4,5,7,8); 3A(1,2,3); 3B(1,2,3), 3C(1,2)
4 A(4,5,6); 4B(4,5,7,8); 3A(1,2,3); 3B(1,2,3), 3C(1,2)"