$re = '/(?:\)[;,]( )|([A-Z\d]+))|./m';
$str = '4A(4,5,6,7,8,9); 4B(4,5,7,8); 3A(1,2,3); 3B(1,2,3), 3C(1,2)
4A (4,5,6,7,8,9); 4B(4,5,7,8); 3A(1,2,3); 3B(1,2,3), 3C(1,2)
4A (4,5, skip 8,9); 4B(4,5,7,8); 3A(1,2,3); 3B(1,2,3), 3C(1,2)
4 A(4,5,6); 4B(4,5,7,8); 3A(1,2,3); 3B(1,2,3), 3C(1,2)';
$subst = "$2$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;