import Foundation
let pattern = #"(?:\)[;,]( )|([A-Z\d]+))|."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
4A(4,5,6,7,8,9); 4B(4,5,7,8); 3A(1,2,3); 3B(1,2,3), 3C(1,2)
4A (4,5,6,7,8,9); 4B(4,5,7,8); 3A(1,2,3); 3B(1,2,3), 3C(1,2)
4A (4,5, skip 8,9); 4B(4,5,7,8); 3A(1,2,3); 3B(1,2,3), 3C(1,2)
4 A(4,5,6); 4B(4,5,7,8); 3A(1,2,3); 3B(1,2,3), 3C(1,2)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)