import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\*(.|[\\r\\n])*?\\*";
final String string = "doSomething('nnnn/* nnnnn *//nnnnn'); // cccccccc\n"
+ "doSomething(\"nnnn/* nnnnn *//nnnnn\"); // cccccccc\n"
+ "/* ccc' cc//cccccc\"ccccc'ccc \n"
+ "ccccccc\n"
+ "ccccccc\n"
+ "*/\n"
+ "doSomething2(111, 222, 333); // .cccc/.cccc /* ???? */\n"
+ "abc.replace(/'/g, 'nnnnn//nnnnn'); /* cccccccc */\n"
+ "abc.replace(/\"/g, 'nnnn'); /* cccccccc */\n"
+ "doSomething(\"<div>nnnnnn//nnnnnn nnnnnn nnnnnn</div>\",1234);// cccccccc\n"
+ "doSomething('<div>nnnnnn//nnnnnn nnnnnn nnnnnn</div>',1234);// cccccccc\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}