// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\*(.|[\r\n])*?\*").unwrap();
let string = "doSomething('nnnn/* nnnnn *//nnnnn'); // cccccccc
doSomething(\"nnnn/* nnnnn *//nnnnn\"); // cccccccc
/* ccc' cc//cccccc\"ccccc'ccc
ccccccc
ccccccc
*/
doSomething2(111, 222, 333); // .cccc/.cccc /* ???? */
abc.replace(/'/g, 'nnnnn//nnnnn'); /* cccccccc */
abc.replace(/\"/g, 'nnnn'); /* cccccccc */
doSomething(\"<div>nnnnnn//nnnnnn nnnnnn nnnnnn</div>\",1234);// cccccccc
doSomething('<div>nnnnnn//nnnnnn nnnnnn nnnnnn</div>',1234);// cccccccc
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}