const regex = /\*(.|[\r\n])*?\*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\*(.|[\\r\\n])*?\\*', 'gm')
const str = `doSomething('nnnn/* nnnnn *//nnnnn'); // cccccccc
doSomething("nnnn/* nnnnn *//nnnnn"); // cccccccc
/* ccc' cc//cccccc"ccccc'ccc
ccccccc
ccccccc
*/
doSomething2(111, 222, 333); // .cccc/.cccc /* ???? */
abc.replace(/'/g, 'nnnnn//nnnnn'); /* cccccccc */
abc.replace(/"/g, 'nnnn'); /* cccccccc */
doSomething("<div>nnnnnn//nnnnnn nnnnnn nnnnnn</div>",1234);// cccccccc
doSomething('<div>nnnnnn//nnnnnn nnnnnn nnnnnn</div>',1234);// cccccccc
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}