$re = '/\*(.|[\r\n])*?\*/m';
$str = 'doSomething(\'nnnn/* nnnnn *//nnnnn\'); // cccccccc
doSomething("nnnn/* nnnnn *//nnnnn"); // cccccccc
/* ccc\' cc//cccccc"ccccc\'ccc
ccccccc
ccccccc
*/
doSomething2(111, 222, 333); // .cccc/.cccc /* ???? */
abc.replace(/\'/g, \'nnnnn//nnnnn\'); /* cccccccc */
abc.replace(/"/g, \'nnnn\'); /* cccccccc */
doSomething("<div>nnnnnn//nnnnnn nnnnnn nnnnnn</div>",1234);// cccccccc
doSomething(\'<div>nnnnnn//nnnnnn nnnnnn nnnnnn</div>\',1234);// cccccccc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);