using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<[^\/]*?>)\s*|\s*(<\/.*?>)";
string substitution = @"$1$2";
string input = @"la la la <h1> text text </h1> bla bla bla <b> text </b>
la la la <h1> text text</h1> bla bla bla <b>text </b>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}