import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<[^\\/]*?>)\\s*|\\s*(<\\/.*?>)";
final String string = "la la la <h1> text text </h1> bla bla bla <b> text </b>\n"
+ "la la la <h1> text text</h1> bla bla bla <b>text </b>";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}