use strict;
my $str = 'la la la <h1> text text </h1> bla bla bla <b> text </b>
la la la <h1> text text</h1> bla bla bla <b>text </b>';
my $regex = qr/(<[^\/]*?>)\s*|\s*(<\/.*?>)/p;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";