$re = '/(<[^\/]*?>)\s*|\s*(<\/.*?>)/';
$str = 'la la la <h1> text text </h1> bla bla bla <b> text </b>
la la la <h1> text text</h1> bla bla bla <b>text </b>';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;