import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.*\\/)*([^\\/\\r\\n]+?|)(?=(?:\\.[^\\/\\r\\n.]*)?$)";
final String string = "filename.ext\n"
+ "filename.\n"
+ "/filename\n"
+ "filename.ext\n"
+ "filename\n"
+ ".filename\n"
+ "/path/.filename\n"
+ "filename.part1.ext\n"
+ "/path_a/path.b/\n"
+ "/path_a/path.b/filename";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}