$re = '/^(?:.*\/)*([^\/\r\n]+?|)(?=(?:\.[^\/\r\n.]*)?$)/m';
$str = 'filename.ext
filename.
/filename
filename.ext
filename
.filename
/path/.filename
filename.part1.ext
/path_a/path.b/
/path_a/path.b/filename';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);