using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\?&]id=\d+$)|(id=\d+&)";
string input = @"xxxxxxxxxxxxx?id=123
xxxxxxxxxxxxx?id=123&xxxxxxxx
xxxxxxxxxxxxx?xxxxxx&id=123
xxxxxxxxxxxxx?xxxxxx&id=123&xxxxx";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}