// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([\?&]id=\d+$)|(id=\d+&)").unwrap();
let string = "xxxxxxxxxxxxx?id=123
xxxxxxxxxxxxx?id=123&xxxxxxxx
xxxxxxxxxxxxx?xxxxxx&id=123
xxxxxxxxxxxxx?xxxxxx&id=123&xxxxx";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}