re = /([\?&]id=\d+$)|(id=\d+&)/m
str = 'xxxxxxxxxxxxx?id=123
xxxxxxxxxxxxx?id=123&xxxxxxxx
xxxxxxxxxxxxx?xxxxxx&id=123
xxxxxxxxxxxxx?xxxxxx&id=123&xxxxx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end