$re = '/([\?&]id=\d+$)|(id=\d+&)/m';
$str = 'xxxxxxxxxxxxx?id=123
xxxxxxxxxxxxx?id=123&xxxxxxxx
xxxxxxxxxxxxx?xxxxxx&id=123
xxxxxxxxxxxxx?xxxxxx&id=123&xxxxx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);