#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^|\s)(?!-123(\s|$))-?[0-9.]+(?=\s|$)"
Local $sString = "102.3 42.89 98 -812.7 -1234 374 5 -123 8 -123 13 -123 21"
Local $sSubst = "\g<1>456"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)