const regex = new RegExp('(^|\\s)(?!-123(\\s|$))-?[0-9.]+(?=\\s|$)', 'gm')
const str = `102.3 42.89 98 -812.7 -1234 374 5 -123 8 -123 13 -123 21`;
const subst = `\g<1>456`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);