import re
regex = re.compile(r"(^|\s)(?!-123(\s|$))-?[0-9.]+(?=\s|$)", flags=re.MULTILINE)
test_str = "102.3 42.89 98 -812.7 -1234 374 5 -123 8 -123 13 -123 21"
subst = "\\g<1>456"
result = regex.sub(subst, test_str)
if result:
print(result)