#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mix)^" & @CRLF & _
"(?<drive>[a-z]:)?" & @CRLF & _
"(?<path>(?:[\\]?(?:[\w !#()-]+|[.]{1,2})+)*[\\])?" & @CRLF & _
"(?<filename>(?:[.]?[\w !#()-]+)+)?[.]?" & @CRLF & _
"$"
Local $sString = "C:.\..\System32\Win.exe"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")