$re = '/^
(?<drive>[a-z]:)?
(?<path>(?:[\\\\]?(?:[\w !#()-]+|[.]{1,2})+)*[\\\\])?
(?<filename>(?:[.]?[\w !#()-]+)+)?[.]?
$/mix';
$str = 'C:.\\..\\System32\\Win.exe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);