import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ "(?<drive>[a-z]:)?\n"
+ "(?<path>(?:[\\\\]?(?:[\\w !#()-]+|[.]{1,2})+)*[\\\\])?\n"
+ "(?<filename>(?:[.]?[\\w !#()-]+)+)?[.]?\n"
+ "$";
final String string = "C:.\\..\\System32\\Win.exe";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}