re = /^
(?<drive>[a-z]:)?
(?<path>(?:[\\]?(?:[\w !#()-]+|[.]{1,2})+)*[\\])?
(?<filename>(?:[.]?[\w !#()-]+)+)?[.]?
$/mix
str = 'C:.\\..\\System32\\Win.exe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end