#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<MM>[01]?[0-9])\/(?<DD>[0-3]?[0-9])\/(?<YYYY>[0-2][0-9][0-9][0-9])"
Local $sString = "mm/dd/yyyy Examples" & @CRLF & _
"" & @CRLF & _
"01/01/2020 #1st Jan" & @CRLF & _
"07/03/2020 #3 July" & @CRLF & _
"12/2/2020 #2 December " & @CRLF & _
"4/23/2020 #23 April " & @CRLF & _
"19/39/2020" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")