const regex = /(?<MM>[01]?[0-9])\/(?<DD>[0-3]?[0-9])\/(?<YYYY>[0-2][0-9][0-9][0-9])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<MM>[01]?[0-9])\\\/(?<DD>[0-3]?[0-9])\\\/(?<YYYY>[0-2][0-9][0-9][0-9])', 'gm')
const str = `mm/dd/yyyy Examples
01/01/2020 #1st Jan
07/03/2020 #3 July
12/2/2020 #2 December
4/23/2020 #23 April
19/39/2020
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}