package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<MM>[01]?[0-9])\/(?<DD>[0-3]?[0-9])\/(?<YYYY>[0-2][0-9][0-9][0-9])`)
var str = `mm/dd/yyyy Examples
01/01/2020 #1st Jan
07/03/2020 #3 July
12/2/2020 #2 December
4/23/2020 #23 April
19/39/2020
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}