import re
regex = re.compile(r"(?<MM>[01]?[0-9])\/(?<DD>[0-3]?[0-9])\/(?<YYYY>[0-2][0-9][0-9][0-9])", flags=re.MULTILINE)
test_str = ("mm/dd/yyyy Examples\n\n"
"01/01/2020 #1st Jan\n"
"07/03/2020 #3 July\n"
"12/2/2020 #2 December \n"
"4/23/2020 #23 April \n"
"19/39/2020\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")