#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!666|000)(?!219-09-9999|078-05-1120)[0-8]\d{2}-\d[1-9]-(?!0{4})\d{3}[1-9]$"
Local $sString = "242-35-4646" & @CRLF & _
"242-10-1111" & @CRLF & _
"242-35-4640" & @CRLF & _
"666-35-4646" & @CRLF & _
"000-35-3939" & @CRLF & _
"242-35-0000" & @CRLF & _
"901-35-2828" & @CRLF & _
"343-45-6829" & @CRLF & _
"078-05-1120" & @CRLF & _
"219-09-9999" & @CRLF & _
"323-71-3076" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")