use strict;
my $str = '242-35-4646
242-10-1111
242-35-4640
666-35-4646
000-35-3939
242-35-0000
901-35-2828
343-45-6829
078-05-1120
219-09-9999
323-71-3076
';
my $regex = qr/^(?!666|000)(?!219-09-9999|078-05-1120)[0-8]\d{2}-\d[1-9]-(?!0{4})\d{3}[1-9]$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}