const regex = /^(?!666|000)(?!219-09-9999|078-05-1120)[0-8]\d{2}-\d[1-9]-(?!0{4})\d{3}[1-9]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!666|000)(?!219-09-9999|078-05-1120)[0-8]\\d{2}-\\d[1-9]-(?!0{4})\\d{3}[1-9]$', 'gm')
const str = `242-35-4646
242-10-1111
242-35-4640
666-35-4646
000-35-3939
242-35-0000
901-35-2828
343-45-6829
078-05-1120
219-09-9999
323-71-3076
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}