re = /^(?!666|000)(?!219-09-9999|078-05-1120)[0-8]\d{2}-\d[1-9]-(?!0{4})\d{3}[1-9]$/m
str = '242-35-4646
242-10-1111
242-35-4640
666-35-4646
000-35-3939
242-35-0000
901-35-2828
343-45-6829
078-05-1120
219-09-9999
323-71-3076
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end