using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-|\s";
string substitution = @"";
string input = @"LP-TouchPoint-App
LP-TouchPoint-OnlineVideo";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}