$re = '/-|\s/';
$str = 'LP-TouchPoint-App
LP-TouchPoint-OnlineVideo';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;