re = /-|\s/
str = 'LP-TouchPoint-App
LP-TouchPoint-OnlineVideo'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result