using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"url\(\\[\'|\""]((?!data:|\/).*)\\[\'|\""]\)";
string input = @"url(\'font-awesome.woff\') url(\'bont-awesome.woff\') url(\'/favicon.ico\') url(\'data:whatever\')";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}