$re = '/url\(\\\\[\'|\"]((?!data:|\/).*)\\\\[\'|\"]\)/mUs';
$str = 'url(\\\'font-awesome.woff\\\') url(\\\'bont-awesome.woff\\\') url(\\\'/favicon.ico\\\') url(\\\'data:whatever\\\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);